Future Pinball - BAM Open VR on Oculus Quest 2

TerryRed

Pinball Hall of Famer
Future Pinball-BAM OpenVR on Oculus Quest 2

This page is dedicated to try to get FP Bam OpenVR working on Oulus Quest 2. We'll talk about using both the Oculus Link and the Virtual Desktop wireless solution.




Using Virtual Desktop (VD) Wireless for PC VR!

Great success! Mostly.

OK.. after some testing, here's what I find works very well for me on my system to get very smooth gameplay, and a very nice SS / clean image. No funky ball judder, etc.

My System: i5 9600K CPU, 16 GB ram, GTX 1080, 5GHz router

Not used:
  • Oculus tray Tool is not running
  • no special settings with Oculus Debug Tool (most of what we do is handled by Virtual Desktop)
  • DO NOT use Open Composite for FP! It won't work with Virtual Desktop wireless (so far)
  • normal front-ends to launch tables in VD. While I do have this working... it always causes judder problems. Probably due to VD also capturing my cabinets 4 monitors.
  • PinEvent PuP-Packs (at first). These can cause a heavy judder. Probably due to VD capturing the monitors that the pup-packs are displayed on.

*************** Settings ******************

Steam VR:

  • set to 100% resolution
  • no super sampling / AA, smoothing, etc
Virtual Desktop:
  • buy Virtual Desktop (VD) for Quest (not the Rift Store version!)
  • only use 60Hz for now (FP seems to need 60 or 120Hz to run nicely)
  • get VD working nicely with a good 5G router or better
  • I have my stream and VR settings set to Medium
  • I have my stream and vr bitrate set to the lowest
nVidia Driver:
  • use the settings in the pics below for FP
  • when you have everything running really nice, you can always come back here and up the transparent AA if your system can handle it (I wouldn't go higher than 4)
1602898626042.png



1602898639533.png



Future Pinball:
  • the pic below shows my FP settings
  • I recommend starting with this at first to be sure you'll have good smooth gameplay
  • when you have everything running very nicely, you can always come back and try enabling reflections if your system can handle it

1602898600788.png


BAM:
  • do a clean install of the latest BAM-Open VR (do NOT mix with normal BAM folder). you may want to start with no BAM\CFG files so that your tables will all start with the same settings (that you will create below)
  • now you run FPLoader.exe from BAM Open VR folder from your Virtual Desktop in VR. Try running a table
  • you'll probably see the table below you. Bring up the BAM menu with Q or ~
  • if you get a grey screen...try exiting the table, close FP and try again
BAM VR settings:
  • by default the HOME key (re-center) is F12 (you can change it in BAM menu)
  • In Add-ons: Hide FP logo = true, Hide Overlays = always, Frame Limiter = Off (important)
  • Vsync = OFF
  • AA = x2 or x4. Can be set higher if your system can handle it...but keep it low at first or you may get judder. This setting combined with GPU Transparent AA make all the difference in FP looking crisp and nice... but it also can be a heavy hitter on fps for some tables.
  • Frame Latency = Important! Try each value for yourself. Each person is different. This will help with the table not being in sync with your head movement
BAM Table position:
  • you can adjust the table's position and size and angle in the usual BAM Table menu
  • you can also setup your gamepad to move around in VR in real-time
BAM Lighting and Post Processing
  • older tables would benefit from Presets: Default or Night.
  • newer tables like Ultimate Pro and PinEvent will set this for you per table
  • set what you like for a default setting
  • be sure to use New Renderer only (though "old" tables will look fine with FP Original, don't set that as your default)
Default and Table CFG files:
  • once you have everything looking the way you want, go back to the main menu and make sure you "Save as Default"
  • now ALL tables will use these settings the first time they load
  • you can always choose "Reset to Defaults" for any table at any time (if you mess up another table)...or you can delete their BAM\CFG file
Note: that the tables may not seem smooth until AFTER you have all these settings "correct", and you've exited and reloaded FP-BAM!


Exiting a table and Starting another table:
  • when you exit the table, you'll see you are still in Steam VR. This is ok, and you want to leave it there
  • press the left Oculus controller's Menu button twice to go back to your virtual desktop
  • close FP and reload BAM Open VR and load your next table
  • once the table is loaded, its possible it may not kick into VR, and you may only hear it or see the FP window. If this is the case, then just press the left Oculus Controller's menu button twice to go back into VR
  • enjoy another table!
  • you may need to press the BAM HOME / Reset key each time a table loads to center it
  • repeat the above for exiting and starting a new table (or take off your headset and look at your monitor)
Tables:
  • once you get everything running nice, I suggest trying SLAM's Ultimate Pro tables, and my PinEvent updated tables, some of GeorgeH's updates, Gimli and wild's updates... as they are set for proper lighting and look really good in VR!
  • Star Wars DSA: Epic Space Battles look particularly cool if I do say so myself!
  • older tables should run really well. If needed they can be set to FP Original for it's renderer (which will help with fps)
  • New Tables (Ultimate Pro, PinEvent, etc) MUST use New Renderer, or they will look like ass!
PinEvent PuP-Packs and PUP Stream:
  • DO NOT enable pup-packs or Pup stream until you have all tables working and looking good!
  • once you do... then you can try to enable ONLY the PuP FullDMD and the PUP Stream FullDMD option! Disable the others so VD isn't over burdened! (The table is smart enough to make the Backbox and FullDMD look correct) If the table doesn't run well for you, then keep pup and pup stream disabled!
Once you are all setup... then running the tables is pretty normal. You just gotta switch between VD and BAM VR sometimes... unless you want to take off your VR headset and look at your monitor to change tables, etc.

Not sure what other solution to use for a table switching method without using a typical front-end. I'm open to ideas!





Oculus Quest 2 using Link Cable

****** Using a decent quality Link cable and Open Composite DLL *****

Great success! Mostly.

OK.. after some testing, here’s what I find works very well for me on my system to get smooth gameplay, and a very nice SS / clean image. No funky ball judder, etc.

Your CPU and GPU will greatly determine how well everything can run. Some tables may run really well… whereas others may be much more demanding (newer tables).

My PC Specs:
  • i5 9600K CPU
  • 16 GB DDR4 ram
  • nVidia GTX 1080
I’ve tested numerous tables at 72Hz, 80Hz, and 90Hz at the Quest 2’s standard resolution. Most tables run great but some newer tables (like PinEvent, etc) are more demanding at 90Hz at that resolution and may not play smoothly at 90Hz, but may run fine at 72Hz / 80Hz.

Not used:
  • SteamVR is completely bypassed when using Open composite DLL
  • don’t enable PinEvent PuP-Packs / PuP Stream (at first). These can cause a heavy judder and need a powerful PC. Wait until you have tested all tables and have them running smoothly, and then try enabling this to see if your system can handle it for those tables
Install the Open Composite DLL in BAM OpenVR plug-ins folder
  • I have attached the openvr_api.zip (at the bottom of this post)
  • extract the DLL file from the zip into the BAM Open VR plugins folder
  • overwrite the DLL file already in there (you can backup if you want)
nVidia Driver:
  • use the settings in the pics below for FP
  • you could try enabling the nvidia Low Latency mode as well
  • when you have everything running really nice, you can always come back here and up the transparent AA if your system can handle it (I wouldn’t go higher than 4)
rxICiN9.jpg



MWxWm2N.jpg


Future Pinball:
  • the pic below shows my FP settings
  • I recommend starting with this at first to be sure you’ll have good smooth gameplay
  • when you have everything running very nicely, you can always come back and try enabling reflections if your system can handle it
  • keep vsync OFF and fullscreen enabled
  • you can lower the resolution down to 640×480, since this has no effect on VR, but can affect your GPU performance
SlkoKZh.jpg


Oculus Desktop App
  • be sure your Quest 2 has good and fast USB 3.0 connectivity
  • you can set the resolution and Hz (72 / 80 / 90) in the device settings
  • the higher the Hz and resolution… the better your CPU and GPU needs to be
  • start at resolution 1.0 and 80Hz as a nice middle ground. You can always come back and go higher (if your system can handle it) or lower (if your system can’t handle it) as needed.
Oculus Tray Tool

This is used to change settings for Oculus PC VR without dealing with the Oculus Debug Tool. It can be found here:


Settings:
  • Super Sampling 0 (this comes down to how fast your system is if you want it higher)
  • ASW = Off (though I find if your fps go really low this will still turn on)
  • GPU Scaling = Off
  • Oculus Homeless = Off (no need for this anymore, as you can disable the Home in the desktop app…very recommended!)

For testing, I enable the Visual HUD and set to Performance
  • this shows a real time graph so you can see the Hz and fps
  • it shows on the left what you have Link set to (72, 80, 90)
  • on the right it shows how much headroom you have left for your cpu / gpu
  • if the right side falls too low, then your fps / performance on the left will drop as well
  • If your system is fast… then the left “should” be steady at 72 / 80 / 90 (whatever Link is set to)
  • as long as the left is solid… then the game / head movement / ball movement “should” be nice and smooth!
  • if your fps shows 45 constant while playing… then that means ASW is turning on (your system may be to slow for the table, etc)

BAM:
  • do a clean install of the latest BAM-Open VR (do NOT mix with normal BAM folder). You may want to start with no BAM\CFG files so that your tables will all start with the same settings (that you will create below)
  • now you run FPLoader.exe from BAM Open VR folder from your Virtual Desktop in VR. Try running a table
  • you’ll probably see the table below you. Bring up the BAM menu with Q or ~
  • if you get a grey screen…try exiting the table, close FP and try again

BAM VR settings:
  • by default the HOME key (re-center) is F12 (you can change it in BAM menu)
  • In Add-ons: Hide FP logo = true, Hide Overlays = always, Frame Limiter = Off (important)
  • Vsync = OFF
  • AA = x2 or x4. Can be set higher if your system can handle it…but keep it low at first or you may get judder. This setting combined with GPU Transparent AA make all the difference in FP looking crisp and nice… but it also can be a heavy hitter on fps for some tables.
  • Frame Latency = Important! Try each value for yourself. Each person is different. This will help with the table not being in sync with your head movement

BAM Table position:
  • you can adjust the table’s position and size and angle in the usual BAM Table menu
  • you can also setup your gamepad to move around in VR in real-time

BAM Lighting and Post Processing
  • older tables would benefit from Presets: Default or Night.
  • newer tables like Ultimate Pro and PinEvent will set this for you per table
  • set what you like for a default setting
  • be sure to use New Renderer only (though “old” tables will look fine with FP Original, don’t set that as your default)

Default and Table CFG files:
  • once you have everything looking the way you want, go back to the main menu and make sure you “Save as Default”
  • now ALL tables will use these settings the first time they load
  • you can always choose “Reset to Defaults” for any table at any time (if you mess up another table)…or you can delete their BAM\CFG file

Note: that the tables may not seem smooth until AFTER you have all these settings “correct”, and you’ve exited and reloaded FP-BAM!


Exiting a table and Starting another table:

  • when you exit a table, you must close FP and reload BAM Open VR and load your next table
  • you may need to press the BAM HOME / Reset key each time a table loads to center it

Tables:
  • once you get everything running nice, I suggest trying SLAM’s Ultimate Pro tables, and my PinEvent updated tables, as they are set for proper lighting and look really good in VR! There are many older tables that do look amazing (polygame, blindmankind,etc)
  • Star Wars DSA: Epic Space Battles looks particularly cool if I do say so myself (but it’s VERY demanding and needs a FAST computer and gpu to run smooth)
  • older tables should run really well. If needed they can be set to FP Original in BAM settings for it’s renderer to run much better, and use Default Preset for Lighting
  • New Tables (Ultimate Pro, PinEvent, etc) MUST use New Renderer, or they will look like ass!

PinEvent PuP-Packs and PUP Stream:
  • DO NOT enable pup-packs or Pup stream until you have all tables working and looking good!
  • once you do… then you can try to enable ONLY the PuP FullDMD and the PUP Stream FullDMD option! If the table doesn’t run well for you, then keep pup and pup stream disabled!
Launching Tables:

Once you are all setup… then running the tables is pretty normal.





Good luck!

I'm so happy many of you guys will finally be able to enjoy some of my table updates, and the MANY FP tables out there that work completely in VR (no changes or updates needed) and simply look amazing!





BAM OpenVR FAQ

I run the table from BAM-OpenVR\FPLoader.exe, and it loads and runs. I see the VR options in the BAM menu on the FP window, bit it’s not displaying in VR…

  • make sure that the Mode is set to “OpenVR” and not one of the other options like Static CAM, HappyCab, etc
  • make sure in the Addons menu that “Force Arcade Mode” is ON
  • you may need to exit and restart FP after making these changes

I think it’s running and working in VR but I can’t see the table…
  • try looking around
  • try BAM’s “HOME” key to Reset View
  • try ~ or Q to bring up the BAM menu
  • you may need to choose Reset View in your VR headset
 

Attachments

  • openvr_api.zip
    336.2 KB · Views: 5
Last edited:

TerryRed

Pinball Hall of Famer
@Gimli
@Gin
@ravarcade
@GeorgeH
@polygame
@wild

For those who are wondering.... yes the new Oculus Quest 2 is an excellent headset. Not only because its a great All in One headset (no PC required.... play games anywhere), it also has great specs (90Hz and good resolution).... but also because you can play normal PC VR games using a long USB cable (no video card needed).... or even better...use Virtual Desktop to play PC VR wirelessly!

It's also very cheap! $399 for 64GB, or $549 for 256GB (Canadian)

Quest 2 Specs:
  • Product Weight: 503g
  • Tracking: Supports 6 degrees of freedom head and hand tracking through integrated Oculus Insight technology.
  • Storage: 64GB or 256GB
  • Display Panel: Fast-switch LCD
  • Display Resolution: 1832×1920 per eye
  • Display Refresh: 90Hz
  • SoC: Qualcomm® Snapdragon™ XR2 Platform
  • Audio: Integrated speakers and microphone; also compatible with 3.5mm headphones.
  • RAM: 6GB
  • Battery Life: You can expect between 2-3 hours based on the kind of content you’re using on Quest 2; closer to 2 hours if you’re playing games and closer to 3 hours if you’re watching media.
  • Charge Time: With the provided USB-C power adapter, Quest 2 will charge to a full battery in about 2.5 hours.
  • Adjustable IPD with three settings for 58, 63 and 68mm.
  • Playspace: Stationary or Roomscale supported. Roomscale requires a minimum of 6.5feet x 6.5 feet of obstruction-free floor space.

If considering getting one, I highly recommend getting the better Elite Strap, or even better the Elite Strap with Battery (which also acts as a counter weight). The stock strap is kind of crappy... and you'll want better comfort.

Virtual Desktop for Wireless PC VR has been updated significantly... and despite there being a tiny bit of latency... I am hooked on playing my PC VR games wirelessly now and at a much better resolution!

Future Pinball BAM Open VR looks AMAZING... and on wireless it so cool!

@Gimli
@ravarcade

I remember you guys saying you play FP VR on your phones? If you were wanting a dedicated VR headset... this is the one to get (and a good wifi router). You wont regret it. The only downside is you MUST use your Facebook account to use the headset. I have no problem with this... but some do.
 
Last edited:

Gimli

Pinball Hall of Famer
@Gimli
@Gin
@ravarcade
@GeorgeH
@polygame
@wild

For those who are wondering.... yes the new Oculus Quest 2 is an excellent headset. Not only because its a great All in One headset (no PC required.... play games anywhere), it also has great specs (90Hz and good resolution).... but also because you can play normal PC VR games using a long USB cable (no video card needed).... or even better...use Virtual Desktop to play PC VR wirelessly!

It's also very cheap! $399 for 64GB, or $549 for 256GB (Canadian)

Quest 2 Specs:
  • Product Weight: 503g
  • Tracking: Supports 6 degrees of freedom head and hand tracking through integrated Oculus Insight technology.
  • Storage: 64GB or 256GB
  • Display Panel: Fast-switch LCD
  • Display Resolution: 1832×1920 per eye
  • Display Refresh: 90Hz
  • SoC: Qualcomm® Snapdragon™ XR2 Platform
  • Audio: Integrated speakers and microphone; also compatible with 3.5mm headphones.
  • RAM: 6GB
  • Battery Life: You can expect between 2-3 hours based on the kind of content you’re using on Quest 2; closer to 2 hours if you’re playing games and closer to 3 hours if you’re watching media.
  • Charge Time: With the provided USB-C power adapter, Quest 2 will charge to a full battery in about 2.5 hours.
  • Adjustable IPD with three settings for 58, 63 and 68mm.
  • Playspace: Stationary or Roomscale supported. Roomscale requires a minimum of 6.5feet x 6.5 feet of obstruction-free floor space.

If considering getting one, I highly recommend getting the better Elite Strap, or even better the Elite Strap with Battery (which also acts as a counter weight). The stock strap is kind of crappy... and you'll want better comfort.

Virtual Desktop for Wireless PC VR has been updated significantly... and despite there being a tiny bit of latency... I am hooked on playing my PC VR games wirelessly now and at a much better resolution!

Future Pinball BAM Open VR looks AMAZING... and on wireless it so cool!

@Gimli
@ravarcade

I remember you guys saying you play FP VR on your phones? If you were wanting a dedicated VR headset... this is the one to get (and a good wifi router). You wont regret it. The only downside is you MUST use your Facebook account to use the headset. I have no problem with this... but some do.
Have you tried it with BAM Terry ?
 

Famine

Pinball Nudger
TerryRed,

Firstly, thank you for your numerous posts and guides regarding setup of FP, BAM, and OpenVR.

I'm running BAM-OVR on Steam VR through a wired Quest 2 on a PC with the following specs:
Windows 10
16 Gb ram
i7-9750
Nvidia RTX 2070

I've had some troubleshooting items that I have worked through that I thought you might want to see alternative solutions to as well.

In your post here: https://vpinball.com/forums/topic/future-pinball-and-bam-mega-guide-by-terryred/page/2/

You mention the possibility of experiencing a grey screen when trying to access the in game menu "Q or ~". I've been able to get past this by actually starting a game on the table, and then pressing the menu key. Restarting the table and FP does not solve this on my setup.

I did also experience the juttering issues you describe above, (which is what got me to this forum) however I don't think it has to do with the display or PC limitations. This appears to be a device tracking issue. Display works fine if I hold completely still, however the moment my head has to move, the screen bounces quite a bit. It's like the sensitivity is turned up to 100 and its predicting that the headset is still moving. I've confirmed that this occurs on the PC display as well.

Any thoughts on how to turn the tracking sensitivity down?
 

TerryRed

Pinball Hall of Famer
@Famine

 

Famine

Pinball Nudger
So, that didn't work. doesn't seem to be related to eye sync. Now I'm working on getting a video capture in game... wondering if this is just default behavior and I'm just overly sensitive to the movement.
 

Gimli

Pinball Hall of Famer
So, that didn't work. doesn't seem to be related to eye sync. Now I'm working on getting a video capture in game... wondering if this is just default behavior and I'm just overly sensitive to the movement.
It may be just my system but I have noticed the jitters arent present in freshly installed bam directories...so one of the config files that bam creates with gameplay is the culprate.

So I backupped a jitterfree version of bam and use that to restore my active bam folder once the jitters set in
 

Famine

Pinball Nudger
Thanks @Gimli. I'll try a reinstall then. unfortunately this was mostly a fresh install. Only changes were TerryRed's custom configs. I also tried VPX to see if I'm getting a similar playback issue on that program, but can't seem to get SteamVR to accept it... Fun times!
 

Gimli

Pinball Hall of Famer
If you start with fresh bam folder...I tend to use the bam.zip that has a BAM folder and NOT the BAM install progam....start by playing the fp dummy"new table' first. do not copy any cfg files.

This will give you the simplist setup with no added complications.

See if you get jitter....

Once I am happy with that then I gradually add stuff and save and make a complete copy the current working BAM folder.
 

michel757

Pinball Nudger
Hello,

Really, well done everyone for your great work ....
Sorry for my English, but I only speak the language of the frog eaters.


Since the BAM_v1.5-318 version of 'BAM' in 'vr' with my Quest2 in wifi or link, the image is not stable, it moves a lot as soon as we follow the head.
With Fpsvr, since this version we notice that the cpu frames are in the red at more than 300.
I did a test with a Rifts, the cpu frames are still important but visually we do not feel this phenomenon

This ties in with what Famine said in another post
 

Gimli

Pinball Hall of Famer
Hello,

Really, well done everyone for your great work ....
Sorry for my English, but I only speak the language of the frog eaters.


Since the BAM_v1.5-318 version of 'BAM' in 'vr' with my Quest2 in wifi or link, the image is not stable, it moves a lot as soon as we follow the head.
With Fpsvr, since this version we notice that the cpu frames are in the red at more than 300.
I did a test with a Rifts, the cpu frames are still important but visually we do not feel this phenomenon

This ties in with what Famine said in another post

see my post above yours...
 
Last edited:

Gimli

Pinball Hall of Famer
Gimli,


Thank you for your reply ,I had read your post yet ...
I will redo a clean installation
It seems to be one of the BAM cfg or dat parameters that suddenly causes the shaking.
When you tweak a parameter in BAM menu or use a table developers BAM cfg file there are some things in the BAM folder that get updated. I haven't bothered to figure out which parameter is the culprit.
If you still have the problem I will try to provide a copy of my BAM folder that I am currently using that hasn't been corrupted yet :)
 

michel757

Pinball Nudger
Thank you very much for your answer.

To no longer have this jitter problem, I just need to replace 'BAM.DLL' with version 'v.1.5-317'.

What is strange

It would be super nice if you could send me your configuration
 

Gimli

Pinball Hall of Famer
Thank you very much for your answer.

To no longer have this jitter problem, I just need to replace 'BAM.DLL' with version 'v.1.5-317'.

What is strange

It would be super nice if you could send me your configuration
I think rav tweaked something in the Bam.Dll recently to help the ball rolling look better in VR , maybe that is the problem

thanks for the feedback
 

michel757

Pinball Nudger
hello Gimli,

I will follow your instruction to rebuild A Fresh Bam folder.
I will tell you, if that solved my problem
This phenomenon is already present in version 'BAM_v1.5-318'

thank you
 

Gimli

Pinball Hall of Famer
hello Gimli,

I will follow your instruction to rebuild A Fresh Bam folder.
I will tell you, if that solved my problem
This phenomenon is already present in version 'BAM_v1.5-318'

thank you
I think you are right it is the Bam.dll that is the culprate
The jitter is less if I wear the headset tighter but I don't think that should be the fix
 

Gimli

Pinball Hall of Famer
hello Gimli,

I will follow your instruction to rebuild A Fresh Bam folder.
I will tell you, if that solved my problem
This phenomenon is already present in version 'BAM_v1.5-318'

thank you
@ravarcade

Ok I tested Bam.dlls and the last one that works without jitter on my oculus quest 2 is version 315
 

Attachments

  • BAM_v1.5-315.zip
    27.3 MB · Views: 200

AnonTet

Pinball Wizard
Site Supporters
Hey guys, i'm trying to setup my rig again after a longer absence than I antecipated. As i'm back to VR as well, now with a Valve Index, it has been awesome and smooth at 90Hz (higher really is unnecessary).

I do have a problem though and i'm wondering if you all are also affected and if able to be improved upon, could help with the jitter. Basically, I can't explain the high CPU frame times while the CPU is only at 60% and GPU could have another headset connected to it :)

My rig is a 8600k@5GHz with 16GB RAM DDR4 @2400Mhz CL15 and a MSI gtx1080 at default factory speeds (it is factory OC though).

I'm using BAM 327 but 315 makes no difference either to me.

I've played BAM VR before on lower spec'ed rig with an MSI GTX1050Ti that's not even VR Ready and I don't recall this issue. Granted it was with a VIVE not an Index but it still had to maintain 90FPS.

So, question, are you all also experiencing high CPU frame times when the CPU is far fom 100%? If so, lowering settings or super sampling helps with the jitter? I don't seem suffer from jitter but frame times are frame times and still indicate something is not quite right in this case.

Anyone tried some windows settings like power management and c states disabling... anything you might have found that helped even if only a bit. Example, having vsync helps reducing the CPU frametime for me although I can't correlate this with CPU.

cheers.
/edit
Forgot to mention, i've played other vr games and the high cpu times don't exist. just in BAM VR.
 
Last edited:

Gimli

Pinball Hall of Famer
Hey guys, i'm trying to setup my rig again after a longer absence than I antecipated. As i'm back to VR as well, now with a Valve Index, it has been awesome and smooth at 90Hz (higher really is unnecessary).

I do have a problem though and i'm wondering if you all are also affected and if able to be improved upon, could help with the jitter. Basically, I can't explain the high CPU frame times while the CPU is only at 60% and GPU could have another headset connected to it :)

My rig is a 8600k@5GHz with 16GB RAM DDR4 @2400Mhz CL15 and a MSI gtx1080 at default factory speeds (it is factory OC though).

I'm using BAM 327 but 315 makes no difference either to me.

I've played BAM VR before on lower spec'ed rig with an MSI GTX1050Ti that's not even VR Ready and I don't recall this issue. Granted it was with a VIVE not an Index but it still had to maintain 90FPS.

So, question, are you all also experiencing high CPU frame times when the CPU is far fom 100%? If so, lowering settings or super sampling helps with the jitter? I don't seem suffer from jitter but frame times are frame times and still indicate something is not quite right in this case.

Anyone tried some windows settings like power management and c states disabling... anything you might have found that helped even if only a bit. Example, having vsync helps reducing the CPU frametime for me although I can't correlate this with CPU.

cheers.
/edit
Forgot to mention, i've played other vr games and the high cpu times don't exist. just in BAM VR.
Welcome back AnonTet.
I am using Quest2 with virtual desktop so I can 't really comment on your system but Terry likely could as he has used other setups tethered and untethered
 

AnonTet

Pinball Wizard
Site Supporters
Thanks @Gimli.

The problem doesn't affect the game visually for me but seems to affect the physics. If the Quest2 had the same problem of high CPU frame time I though it could be connected albeit affecting in different ways our headsets.

Anyway, i'll keep trying on my side and post if I find something, just in case it can help with Quest2.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    @ Todd: **** **** **** *** ** ***** *** ******* *** *** ***** ***** ** ***** *** *** **** *** **** ** ****
    Top