• Google Translate to French or Other Languages Click on the link and a new tab will open with this page translated into French.
    Click on the "To:" pull down option to select a different language. Users will not be logged in on the new Google tab.

Some explanations needed...

Paolo

No Bam no Play
Chat Moderator
Site Supporters
If someone could tell me what happens (right flipper), he's wellcome!
have you updated to the latest version of bam JP?i don't think you have a pc, lower than mine, if i have no problems in mine .... about shadows, you shouldn't have them, but it looks like something about shadow color, as shiva suggests......but I don't think it's a bug ...
 

Popotte

Flipper is good for you!
Site Supporters
Same punition with last BAM version... This happens only with this table and only with the right flipper...
 

Popotte

Flipper is good for you!
Site Supporters
The only code I have is for mini playfield (creation and moveto).

Dim MiniPlayField_0 ' Xmin Xmax Ymin Ymax Zmin Zmax CenX CenY CenZ
Set MiniPlayField_0 = xBAM.CreateMiniPlayfield( -700, -20, 0, 640, -0, 32, -360, 320, 0)

Dim MF ' X Y Z Range Strength
Set MF = xBAM.CreateMagneticField( 329.6, 3.5, 174.8, 20, 0)

' DstX DstY DstZ RotX RotY RotZ Scale Time
Call MiniPlayField_0.MoveTo( 257, -11.5, 422.6, -90, 0, 0, 1, 0)
Call MiniPlayField_0.SetGravity( 90, 0, 1)
 

Paolo

No Bam no Play
Chat Moderator
Site Supporters
ok, you don't have any codes that relate to the shadow in any way,you try this....you go in menu bam....addons, then, under config ball....you put to 0 in the line "dark level"the shadows should disappear ...but it is a test not a solution, unless you no longer want to see the shadows ... so see if it still gives you that problem .....

but if you want to send me the table, so I can see if it creates this unusual problem for me too .....
 
Last edited:

TerryRed

Pinball Master
I've been using the shadowcolour feature very extensively in RetroFlair 2's wip. I havent seen any bugs with it so far.
 

Popotte

Flipper is good for you!
Site Supporters
ok, you don't have any codes that relate to the shadow in any way,you try this....you go in menu bam....addons, then, under config ball....you put to 0 in the line "dark level"the shadows should disappear ...but it is a test not a solution, unless you no longer want to see the shadows ... so see if it still gives you that problem .....
.....
OK, it's fine now with 0. Thanks for the help.
 

Paolo

No Bam no Play
Chat Moderator
Site Supporters
I agree with Shiva. It looks like a bug in the new feature
but why say it's a bug, if we don't all have this problem? George you have this problem too, yes / no, you don't specify it, but I think not

OK, it's fine now with 0. Thanks for the help.
JP, as I told you before, it is not a solution, but it was to understand, remove the shadows, it is at the discretion, but if you publish a version without shadows, for example I like them, I will put them back, and until we understand what happens to you in this table, it could happen to others ..... i think it has something to do with the pc ..... as shiva suggests, but not a bug of bam .... at least until we have certainty

send me the table please, do not be afraid I will delete it as soon as I do the test, so I can see if I also have this problem, so we can understand what it is, and possibly tell Rav ..... and also a way to help
 

Paolo

No Bam no Play
Chat Moderator
Site Supporters
please ask the staff, to transfer this thread to shadow color thred, so as to have only one discussion topic
 

Paolo

No Bam no Play
Chat Moderator
Site Supporters
JP....use this code if you really want shadows not to be used
xBAM.SetBallShadows 0.0 , 0.0 , 0.0 , 1

or you go in the line"dark level" ctrl+c ..so you copy.....then you go in the script ctrl+v, you paste
 

TerryRed

Pinball Master
Yes, what wild is trying to see, is if the shadows need to be offset from the playfield a little as they may be at 0 offset, which may have them displaying on the exact same height as the playfield


The last number in xBAM.SetBallShadows is the height / offset of the shadows.
 

GeorgeH

Flippered Out
Staff member
Site Supporters
but why say it's a bug, if we don't all have this problem? George you have this problem too, yes / no, you don't specify it, but I think not
I haven't really tested it that much but I did get a red shadow on the demo table. I am not sure if it was supposed to do this or not. There aren't many directions so I am not sure what is right.

I remember @popotte used to have a special version of windows that caused a problem with BAM a few years ago. I'm not sure if he still has it or not. It was Windows 7 N which was issued to some European countries and did not include Windows Media Player.
 

Popotte

Flipper is good for you!
Site Supporters
JP....use this code if you really want shadows not to be used
xBAM.SetBallShadows 0.0 , 0.0 , 0.0 , 1

or you go in the line"dark level" ctrl+c ..so you copy.....then you go in the script ctrl+v, you paste
As I really don't know what shadows do (or don't do), I'll just add your line in the script. No more trouble with my problem and no other visible changes.
The last number in xBAM.SetBallShadows is the height / offset of the shadows.
No problem with that, but why it's only the right flipper affected (infected?)? And why only for this table (the only difference with my others is mini playfield use)?
I remember @popotte used to have a special version of windows that caused a problem with BAM a few years ago. I'm not sure if he still has it or not. It was Windows 7 N which was issued to some European countries and did not include Windows Media Player.
This is not really a special version (Europe is not a little world's region). But, OK, you have some differences with 7's version (and I think 10's version) -> manual ball rolling for example.

Many thanks for your advices.
 

TerryRed

Pinball Master
The flipper shadow "colours" can be controlled per flipper using a different command. Whereas the SetBallShadows is what sets the size / radius / offset for all flippers and ball shadows.

Not sure why you are seeing this only on this table.
 

Paolo

No Bam no Play
Chat Moderator
Site Supporters
No problem with that, but why it's only the right flipper affected (infected?)?
JP ... "we" are the infected with "pinball mania" ....joke:bonk:
one question, what kind of miniplayfield do you have on the table? i mean what objects are interested on it? it's not that the orange box somehow touches the "right-flipper"?
 

GeorgeH

Flippered Out
Staff member
Site Supporters
This is not really a special version (Europe is not a little world's region). But, OK, you have some differences with 7's version (and I think 10's version) -> manual ball rolling for example.
I call it "Special" because you couldn't get it in the U.S.A. I have Windows 10 and don't have a problem with the ball roller. I assume you are still using Windows 7N.
 

Popotte

Flipper is good for you!
Site Supporters
JP ... "we" are the infected with "pinball mania" ....joke:bonk:
one question, what kind of miniplayfield do you have on the table? i mean what objects are interested on it? it's not that the orange box somehow touches the "right-flipper"?
Not really. Mini playfield goes into the back box.
 

Paolo

No Bam no Play
Chat Moderator
Site Supporters
Not really. Mini playfield goes into the back box.
ahhh,,ok.....so JP....I have nothing more to say to you, sorry ..I have no other options if you don't send me your version I can no longer do anything, or tell you what it could be......this is a shame, because if by a strange case there should be some strange problem in the function, we will not know what it could be, and then, tell to Rav ...... I can't call it a bug, until nor do I have certain proof, or that it could happen to another.

regards
 

TerryRed

Pinball Master
I think what Popotte is that his table has a miniplayfield on the back box

I know most of you guys are not cabinet players...

...but a not fun fact. Mini playfields displayed on the Translite / Backbox won't show up on the FP Backbox / 2nd monitor in Arcade / Cabinet mode.

They only work on the main playfield monitor or in VR / desktop modes.

So on tables like Wild's NES table.... you can't play that on a cabinet.

Something to think about if a cabinet users has problems with a table that use mini playfields in this way.
 
Last edited:

Paolo

No Bam no Play
Chat Moderator
Site Supporters
I think what Popotte is that his table has a miniplayfield on the back box

I don't see this comment ???

so I don't know why Terry answered, and I don't understand what we're talking about

however I think I understand the mystery of the pulsing phantom fin:ghost:

EDIT:
however I can say that it is not a bug of the new feature
 
Last edited:
General chit-chat
Help Users
  • No one is chatting at the moment.
    @ Paolo: ********* *** ******
    Top