Why does FranzLeo's version of SkyWay crash for some people? [solved]

Isaac Sauvage

Meep!
Site Supporters
Consultant
This rather unique table was mentioned recently on Reddit, and I figured I'd give it a whirl. We have some pretty nice versions here, and I wanted to see how the FP version looked and played.

Starting with @franzleo's low-res version, I tried it with two different versions of FP, and then via BAM-FP. Every time it crashed on the loading screen.

My attempt to run it via the F9 debug window didn't seem to help, and I couldn't find any error reports. Others seem to have also had problems based on these comments over at PSDB:

jaynong on 2015-03-24
Table version : 4.00

I tried the high and low res but it crashes.

nanuk on 2015-03-15
Table version : 4.00

crash fp

massico88 on 2015-01-22
Table version : 4.00

I load the table..but just wont start..stay on the background pic.. anyone can help ??
Thank you.

Maybe this rings a bell for someone...?

EDIT: Attached a screenshot for the heck of it.
 

Attachments

  • sky way.png
    sky way.png
    1.6 MB · Views: 36
Last edited:
Solution
Okay, got it-- model quality had to be set to "high" in settings. All three tables now work.

I didn't realise you could actually be too modest for a table's needs with the video settings.

Now I wonder how many other crashy tables I experienced will start working with this?

Isaac Sauvage

Meep!
Site Supporters
Consultant
I double-checked that I had "load image in to table editor" unchecked, and that Video / Rendering options were at the minimum preset.

Same thing-- the progress bar fully completes on the loading screen, then FP disappears.

Then I tried taking all the upper half settings down to their basic values, as seen below. I even tried the table windowed at 640x480 (I think that was it), and it still crashed.

settings.jpg


So I'm getting the sense that the problem here isn't about over-maxing my settings, but rather some basic incompatibility with my hardware. But since a lot of FP tables run okay for me (aside from more complex tables that really push the table elements and graphics), the problem seems to be this table specifically. As in, something in the layout or script.

What could it be...? At least three other commenters also had this problem starting in 2015. I would have thought someone figured it out back in the day, but maybe not.

I still don't know if there's another way to snag an error report outside of running in F9 mode. But I guess one more thing I could try would be to run a couple more of Franzleo's tables from this same period. I.e. maybe there's something he's doing with this one table that trips up some systems.
 

Isaac Sauvage

Meep!
Site Supporters
Consultant
Okay, I tried two more of his solo re-creations. One came right before and one came right after SkyWay. The tables were "Big Ben" and "Gusher," specifically.

Both crashed the same way. I also saw a suggestion to check "vertical sync," but that didn't help either.

Finally, I tried blanking out one of the scripts. This should have at least created a rendered version of the game, even if it couldn't do anything. Crash again.

My working conclusion is that Franzleo's doing something in the layout (not the script) that my setup is incompatible with. Unfortunately, I don't have remotely enough FP experience to know what that might be.
 

Isaac Sauvage

Meep!
Site Supporters
Consultant
Okay, got it-- model quality had to be set to "high" in settings. All three tables now work.

I didn't realise you could actually be too modest for a table's needs with the video settings.

Now I wonder how many other crashy tables I experienced will start working with this?
 
Last edited:
Solution

GeorgeH

Flippered Out
Staff member
Site Supporters
Now I wonder how many other crashy tables I experienced will start working with this?

I am guessing quite a few. I just noticed your posting or I would have responded sooner. In order for BAM to work, model quality must be set to "high". The 2 in 1 installer sets this automatically and automatically unchecks "load image in to table editor" .

Are you interested in trying Attack From Mars? You said you played the real table and I would like some feedback on how close it plays to the real table. If it crashes, it crashes but it loads quickly on my PC.
 

Isaac Sauvage

Meep!
Site Supporters
Consultant
@GeorgeH,
Good to know it's a BAM thing. Hopefully this kind of useful info is collected somewhere, because even though the 2-in-1 installer does its thing, that doesn't prevent people from naturally playing around with settings over time.

Btw, I noticed that you and some others tend to check for new posts by looking at the forum page. But a really useful way of making sure you don't miss new content is to use one of the "What's new" commands. For example New posts. I'd recommend to anyone that they use that instead.

Yeah, I played a tonne of AFM back in the day. It's been maybe 15 years, but I'll take a look if you like.
 
Last edited:
General chit-chat
Help Users
  • No one is chatting at the moment.
  • @ 20degree:
    *** *** **** **** ********* *** *** * ****** *** *** ************ ** *** ***** *** **** ** ******* ** *** ***** ****** ******** **** **** ************ **** **** ******
    Quote
  • @ xenonph:
    * * ****** *** ***** **** * *** *** **** **** ******* *** *** *** *** **** ** *****
    Quote
    @ xenonph: * * ****** *** ***** **** * *** *** **** **** ******* *** *** *** *** **** ** *****
    Top