BAM FP Future Pinball - BAM OpenVR on Meta (Oculus) Quest 1/2 and Rift / Rift S

Future Pinball

TerryRed

Pinball Master
I have always had a hard time with link (Steam VR or OC). I haven't tested either recently (I can't do much in VR, as I'm still recovering from my stroke).

.. but I did a fresh Win 10 install, Oculus, SteamVR, and the latest BAM Open VR 1.5-351.

My PC is i5 9600K, RTX 3080.

Running the newest Sonic FizX using Virtual Desktop Wireless (using the settings above at 60Hz), it looks and runs fantastic.

Using Link with OC or SteamVR means you can't run at 60Hz, and there's more settings to deal with using either Oculus Rift Desktop App, or Steam VR... or both. One could affect the other poorly. So I can't give an update on either right now.

That said... you MUST have Steam VR completely closed AND the VR Server process completely closed BEFORE you start FP and load a table with Quest 2.... every time!

==================

Using Virtual Desktop Wireless... here is my BAM OpenVR install (1.5-351) with all the settings setup like I use in this guide. You cannot use Open Composite with Virtual Desktop Wireless! It gives you the error you showed us. I had Sonic FizX running really nicely with it. Keep in mind.... newer tables are going to be more demanding compared to older tables. So if something isn't setup right, or your PC isn't keeping up... then it will have the ball stutter, etc

Try a fresh reboot, install my BAM files below (backup your current BAM OpenVR first)... then make sure you patch the FuturePinball.exe for 4 GB! (you will probably get an error if you don't). Then start Virtual Desktop, with the settings I show.... be sure Steam VR and VR Server aren't running... then try running a table.
 

Attachments

  • BAM-OpenVR - VD.zip
    5.1 MB · Views: 24

Brodzowski

Pinball Nudger
Followed your instructions perfectly - loaded up and strangely the ball wasn't quiiiiite as bad as it was before but I can still see it. Again - recorded video shows nothing. The spinning sign is VERY bad - some of the dmd changes do it as well, but the exact same result. Something between the computer and what my quest is feeding my eye because I can't get it to show on video. I also have a pinevent 2.txt error at the top of the screen but it didn't stop me from playing. I know that's not related, but it was there. Thanks for any extra insight you might have. It's obviously NOT my FP installation. It's got to be something I've got set on my headset.
 

TerryRed

Pinball Master
Be sure that any PinEvent 2 table is in Tables folder, and not in a sub folder. Also, be sure to install the Pinevent_V2_Settings.txt in the FuturePinball\Scripts folder.

If you still get an error for the txt file... then something on your system is restricting access to the file or restricting BAM from working correctly, etc.

One person just enabled PinEvent Custom settings in the table script, and the error went away.... but normally you should never have to do that (only 2 people out of 1000's reported that issue)
 

Brodzowski

Pinball Nudger
Make that 3. I had the file in there and my table was in the Tables folder. - enabled that in the script and the error went away. /shrug ---- didn't do anything for my visual issue of course, but it did fix the error. I tried some other tables too and it's not just yours. The flippers do it pretty badly because of how fast they move. It's very hard to explain but almost like it's out of sync. Your dmd does is mildly too as it's flipping through the options before launching the ball. It's something to do with fast moving objects.
 

kamicki

Pinball Nudger
Make that 3. I had the file in there and my table was in the Tables folder. - enabled that in the script and the error went away. /shrug ---- didn't do anything for my visual issue of course, but it did fix the error. I tried some other tables too and it's not just yours. The flippers do it pretty badly because of how fast they move. It's very hard to explain but almost like it's out of sync. Your dmd does is mildly too as it's flipping through the options before launching the ball. It's something to do with fast moving objects.
I have the exact same issue with Quest 2 on the most recent BAM-OpenVR. Have you found a fix for it?
 

Brodzowski

Pinball Nudger
I did not. When the guru doesn't have an answer - then I kind of assumed I was being picky or it was me / my gear etc. Glad to hear I wasn't crazy at least, but sadly no - problem persists after all my troubleshooting.
 

kamicki

Pinball Nudger
I have just tried unzipping all the files from the archive attached by TerryRed and it looked much better after that (still visible though). Then I thought it's a little too dark for my liking and used BAM menu to restore default light settings. And after that the issue is much much worse than before. Maybe the light settings are the culprit? I'll try to tinker with that next time.

BTW for me it looks like moving objects "stick out". It can be visible at DMD, when DMD text is moving it pops out of the DMD frame or something like that. Very immersion-breaking. If I had to guess I'd say it's an issue with sync between left and right eye-view.
 

Gimli

Pinball Master
@Brodzowski
I have just tried unzipping all the files from the archive attached by TerryRed and it looked much better after that (still visible though). Then I thought it's a little too dark for my liking and used BAM menu to restore default light settings. And after that the issue is much much worse than before. Maybe the light settings are the culprit? I'll try to tinker with that next time.

BTW for me it looks like moving objects "stick out". It can be visible at DMD, when DMD text is moving it pops out of the DMD frame or something like that. Very immersion-breaking. If I had to guess I'd say it's an issue with sync between left and right eye-view.
Did you guys give the specs of your pc's, GPU's etc ?
Also in BAM menu (presss Q or `) take a screen shot.

Here are screen shots of my settings for everything except BAM menu....
 

Attachments

  • Bob System and settings.zip
    1.1 MB · Views: 12

Brodzowski

Pinball Nudger
I'm pretty sure I mentioned what mine were, but... With a 3080. I should be fine.
 

Attachments

  • System.jpg
    System.jpg
    135.7 KB · Views: 16

kamicki

Pinball Nudger
I'm pretty sure I mentioned what mine were, but... With a 3080. I should be fine.
I have only i7-7700K + GTX 1080. I eventually found that for me the issue is connected to the low performance. I switched from Air Link to Virtual Desktop and tried 90fps, Mid Quality. I looked at the performance overlay and saw that game doesn't hit 90fps. It fluctuates between 75-85. So I lowered the VD setting to 72 fps and the problem was gone (all the time using files that I unzipped from the archive attached by TerryRed). Now I switched to Low quality 90FPS and the HW keeps up and it looks okay.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
  • @ freebird1963:
    *** ******* ** *** **** **** ** **** ** **** *** *** **** * * ***** *** *** ***** ** ******** ***** **
    Quote
  • Chat Bot Mibs:
    ***** *************** *** ****** *** *****
  • (Guest) fuckedupthemath:
    ****
    Quote
  • (Guest) fuckedupthemath:
    ****
    Quote
  • (Guest) fuckedupthemath:
    *****
    Quote
  • (Guest) fuckedupthemath:
    ***********************************
    Quote
  • Chat Bot Mibs:
    ***** **** *** ****** *** *****
  • (Guest) test:
    **
    Quote
    (Guest) test: **
    Top